PDA

View Full Version : OpenPLi-4.0-beta-dm800se SSL #84d by gjstroom



Pages : [1] 2 3

gjstroom
27-09-2013, 10:56 PM
OpenPLi-4.0-beta-dm800se #ssl84d

Finaly OpenPLi 4.0 with SIM2 SSL84d and all original 20131001 drivers.

http://i.imgur.com/EcASuC7.png

This image is a 100% build image from OpenPLi source, it uses all original 20131001 drivers which can run all plugins without patching.
You can use the update function, but if the PLi team switches to a new driver or ssl you may end up with a non functional box (which is an easy fix).
Check the Openpli Oe Core history (http://sourceforge.net/p/openpli/openpli-oe-core/ci/4e13de2aefe6fec3de8ba585fa80a38c82409315/log/?path=) to be sure. You can find all Enigma2 changes here (http://sourceforge.net/p/openpli/enigma2/ci/69cb607d24ebd34f831cd50af930236c3d7ec601/log/?path=).

OpenPli 4.0 is build on a newer build environment as OpenPli 3.0, also newer versions of libcrypto and libssl are included which can cause some plugins to fail.

Features:
source: daily build
drivers: 20131001
bootloader: ssl84d
size:47.0 mb

http://img163.imageshack.us/img163/3599/885f.png

Bootlogo:
standard bootlogo

Plugins:
No additional plugins installed, use the plugins menu and download with the green button.

Skins:
PLi-HD

http://img845.imageshack.us/img845/6358/hj4c.png

Image flashing:
Be sure you have SSL84 (http://www.dreamoem.com/attachment.php?attachmentid=128&d=1323833483) on your box, if you get the "INVALID IMAGE (OR OLD VERSION)" error, flash SSL84 (http://www.dreamoem.com/attachment.php?attachmentid=128&d=1323833483) first and try again.
If your box is already at SSL84x you can flash the image immediately, the new SSL84b is included in the image !
Internet Explorer (recommended)
SUNRAY-FlashUP
Powercycle after flashing

OpenPLi-4.0-beta-dm800se #ssl84d ac3+ DailyBuild:

<-Daily Build Download-> (Note: if the link fails use the archive link beneath) (https://dl.dropboxusercontent.com/u/9860949/dm800se/dm800se-4daily.html)


<-Download-> (https://mega.co.nz/#F!0x42XbRQ!7-F4WizaWSM12znv-o-LiQ)

thermeus
28-09-2013, 04:58 PM
Works fine, big thanks ! ;)

chandra
28-09-2013, 06:34 PM
Hi , Great to see this.. flashed..and is working.

gjstroom
28-09-2013, 06:56 PM
I resized the bootlogo.mvi, the one PLi delivers doesn't work proper for the dreamboxes. New image in start post.
There's also some discussing about this on the PLi board, they blame the driver, because is working well on the other boxes, I blame the mvi itself...

About AC3+, the gst-plugin-dvbmediasink does support it now, but also the a new driver is needed (20130927). This driver is not patched yet to work on our SIM2 boxes.

dreambox-dvb-modules: updated dm500hd, dm500hdv2, dm800se, dm800sev2, dm7020hd hardware drivers
- updated audio core
- added DDP aka AC3+ support

Marlboro_HD
28-09-2013, 08:51 PM
is possible in this image to change mac address in startup ?
in oe 1.6 edit interfaces file in etc/network and worked fine , i try it in pli but no success.

gjstroom
28-09-2013, 09:12 PM
I think something like this should work:
ifconfig eth0 hw ether 01:02:03:04:05:06
put the script in /etc/init.d/yourscript, and create a symlink /etc/rc3.d/S01yourscript to /etc/init.d/yourscript

MANIAS21
29-09-2013, 12:45 AM
I resized the bootlogo.mvi, the one PLi delivers doesn't work proper for the dreamboxes. New image in start post.
There's also some discussing about this on the PLi board, they blame the driver, because is working well on the other boxes, I blame the mvi itself...

About AC3+, the gst-plugin-dvbmediasink does support it now, but also the a new driver is needed (20130927). This driver is not patched yet to work on our SIM2 boxes.

dreambox-dvb-modules: updated dm500hd, dm500hdv2, dm800se, dm800sev2, dm7020hd hardware drivers
- updated audio core
- added DDP aka AC3+ support



As you calculate time?


.

rameez364
29-09-2013, 02:50 AM
can i install this image in external flas/.

maoui
29-09-2013, 08:09 AM
thanks
1- is there possibility to use barryallen to install this new image in external flach ???
2- when we install this new image in internal flach ; we can install barryallen in this image ???

MANY QUESTIONS about barryallen for this new images ......if you can explain and test

gjstroom
29-09-2013, 09:08 AM
I never use Barry Allen, but from what I have read, it doesn't work.
You can try Flodder. http://www.oozoon-board.de/wbb/index.php?page=Thread&threadID=973&52dbbffb

gjstroom
29-09-2013, 09:12 AM
As you calculate time?
I think the question is, can you give a estimated time ?
The answer is no, I don't do the driver patching, I asked team SIM to patch the latest driver version. Time will tell...

voyger
29-09-2013, 11:58 AM
here work fine PLI 4
on my DM800se i had last IMAGE 2.1 by gjstroom..flash IMAGE PLI4 by gjstroom by webbrowser all work lovely
did install Dflash crossepg all work ok..thankyou gjstroom lovely IMAGE..
OpenWebif work ok

maybe some people they should read and understand before flash a IMAGE..don't get where people get no existing error of there own make

voyger
30-09-2013, 12:21 PM
tried to update the IMAGE lost the tuner and the boot-logo..so pleas don't update the IMAGE if you don't know the how to to get back..

got it back on put back the tuner BMC 7405 and boot-logo work perfect

voyger
30-09-2013, 03:35 PM
hi gjstroom
as i said above today did update the IMAGE lost the bootlogo when the box start is black screen no bootlogo did send the boot logo bat still no boot logo
can you tell us how i can go around to install..

thankyou

gjstroom
30-09-2013, 04:22 PM
Warning

OpenPli added the new 20130927 drivers to their image and update feed. When you preform a online update, your box will update the driver with a non patched one. This results in no bootlogo (the autumn picture) and no tuner found.

You can bypass this for now by editing the /var/lib/opkg/status file

Search for the line "Package: kernel-module-bcm7405"
change the line "Version" line in this section.


Version: 3.2-20130607-r7.0
change to
Version: 3.2-20130927-r7.0


After the edit you can do a save update again.

Fix if you already did a update without editing the 'status' file


cd /lib/modules/3.2-dm800se/extra
rm bcm7405.ko
wget http://dl.dropboxusercontent.com/u/9860949/dm800se/bcm7405.ko
reboot

voyger
30-09-2013, 05:21 PM
thankyou gjstroom

as i said did fix the tuner did change the tuner work ok is the boot-logo (the autumn picture) at the reboot is not there how do i fix that??

Package: dreambox-dvb-modules-dm800se
Version: 3.2-20130927-r7.0
Depends: kernel-module-stb-core, kernel-module-bcm7405, kernel-module-dreambox-keyboard, kernel-module-lcd, kernel-module-lnb-ctrl, dreambox-secondstage-dm800se, kernel-3.2-dm800se, kernel-module-alps-bsbe1-c01a, kernel-module-tu1216, kernel-module-dreambox-rc2, kernel-module-stv0299, kernel-module-helper, kernel-module-alps-bsbe1, kernel-module-tmp100, kernel-module-alps-bsbe2, kernel-module-bcm4506, kernel-module-cxd1981, kernel-module-cu1216mk3
Status: install user installed
Architecture: dm800se
Installed-Time: 1380557678
Auto-Installed: yes

gjstroom
30-09-2013, 05:42 PM
I think you're not using the last image from the startpost ? I already put a new one several times over there...
Download this file and place it in /usr/share (overwrite the existing one).
https://dl.dropboxusercontent.com/u/9860949/dm800se/bootlogo.mvi
Also read this: http://dreamoem.com/showthread.php?8313-OpenPLi-4.0-beta-dm800se-by-gjstroom&p=31232&viewfull=1#post31232
The proper display of the original bootlogo depends on some factors beyond my comprehension.... Some software install or other updates leads to fail in display (or partial). That's why I resized it.

alex873
30-09-2013, 05:57 PM
I try update status file before update process

But i lost tunner & bootlogo

also before wget http://dl.dropboxusercontent.com/u/9860949/dm800se/bcm7405.ko you must delete or rename original file.
This solutions works fine.



root@dm800se:/lib/modules/3.2-dm800se/extra# wget http://dl.dropboxusercontent.c
om/u/9860949/dm800se/bcm7405.ko
Connecting to dl.dropboxusercontent.com (50.19.217.218:80)
wget: can't open 'bcm7405.ko': File exists


Regards

voyger
30-09-2013, 06:32 PM
thankyou gjstroom
now all work perfect...did miss the other post.. very very good IMAGE nice work..

would like to ask you if you know is there any possibility to patch dreamelite??
did try but no success

regards

maoui
30-09-2013, 06:44 PM
thankyou gjstroom
now all work perfect...did miss the other post.. very very good IMAGE nice work..

would like to ask you if you know is there any possibility to patch dreamelite??
did try but no success

regards
hello
can you post us your new backup with this new image with cccam installed
thanks

gjstroom
30-09-2013, 06:56 PM
No, I only make clean images. You can download the cccam plugin yourself, just go to Menu - Plugins - Download plugins (green button) - softcams

Silsila
30-09-2013, 07:14 PM
Thanks for this image gjstroom. Is there any word on a patched driver DM500HD Sim 2.10 version, as the specs of these boxes are almost identical apart from a few cosmetics. Cheers.

gjstroom
30-09-2013, 07:16 PM
I try update status file before update process

But i lost tunner & bootlogo

also before wget http://dl.dropboxusercontent.com/u/9860949/dm800se/bcm7405.ko you must delete or rename original file.
This solutions works fine.

Sorry guys, my fault. I was replying on auto pilot.
It's not the package dreambox-dvb-modules-dm800se which is updated, but it's just the kernel module: kernel-module-bcm7405_3.2-20130927
I will edit my previous fix !

alex873
30-09-2013, 07:40 PM
Sorry guys, my fault. I was replying on auto pilot.
It's not the package dreambox-dvb-modules-dm800se which is updated, but it's just the kernel module: kernel-module-bcm7405_3.2-20130927
I will edit my previous fix !

Thanks gjstroom.

Now we only need patch bcm7405.ko and we have our dreams perfect with AC3+ sound.

Regards.

gjstroom
30-09-2013, 07:48 PM
Thanks gjstroom.
Now we only need patch bcm7405.ko and we have our dreams perfect with AC3+ sound.

We already asked team SIM do patch the latest driver version. I'll hope to get a update soon.

gjstroom
30-09-2013, 09:15 PM
New image in start post, this one has for all dvb-modules the version set to 3.2-21130927-r7.0. So that's 100 years in the future ! No more driver update problems in the near future (I hope...).

amir8695
30-09-2013, 10:08 PM
hello bro i instali this image every think ok but after i update the software my tuner is empty help my dm 800se sim2...... thanks

noriislam
30-09-2013, 11:58 PM
enigma2-plugin-extensions-tspanel_7.3_mips32el for OpenPLi-4.0-beta-dm800se #ssl84b

http://img15.hostingpics.net/pics/553532833.jpg (http://www.hostingpics.net/viewer.php?id=553532833.jpg)

2309

DOWNLOAD (http://shrta.com/files/YVCWCA4U/enigma2-plugin-extensions-tspanel_7.3_mips32el.ipk)

DOWNLOAD (http://www.sendspace.com/file/cof99t)

gjstroom
01-10-2013, 09:09 AM
hello bro i instali this image every think ok but after i update the software my tuner is empty help my dm 800se sim2...... thanks
Maybe put some effort in it and try to read some pages... it's al there !

MastaG
01-10-2013, 12:44 PM
Would it be possible to update from your previous image (based on OE1.6 with 2.6 drivers) to OpenPLI 4.0 by replacing the feeds?
Sort of like a distupgrade.. or did they change the flashmap?

sunrayfck
01-10-2013, 01:14 PM
gjstroom,

Possible to get the ipk or archive with all files on the driver folder or a link to download them all from your dropbox,

Thanks

fck

Like here for the 27.09.2013 ones :
27.09.2013 19:54 8'628 alps_bsbe1.ko
27.09.2013 19:54 28'380 alps_bsbe1_c01a.ko
27.09.2013 19:54 50'420 alps_bsbe2.ko
27.09.2013 19:54 107'720 bcm4506.ko
27.09.2013 19:54 4'317'348 bcm7405.ko
27.09.2013 19:54 11'828 cu1216mk3.ko
27.09.2013 19:54 23'484 cxd1981.ko
27.09.2013 19:54 8'444 dreambox_keyboard.ko
27.09.2013 19:54 11'720 dreambox_rc2.ko
27.09.2013 19:54 2'400 helper.ko
27.09.2013 19:54 26'840 lcd.ko
27.09.2013 19:54 1'505 LICENSE
27.09.2013 19:54 10'396 lnb_ctrl.ko
27.09.2013 19:54 30'544 stb-core.ko
27.09.2013 19:54 3'164 tmp100.ko
27.09.2013 19:54 50'012 tu1216.ko


New image in start post, this one has for all dvb-modules the version set to 3.2-21130927-r7.0. So that's 100 years in the future ! No more driver update problems in the near future (I hope...).

noriislam
01-10-2013, 04:10 PM
hello
can you post us your new backup with this new image with cccam installed
thanks

use the tspanel here
http://www.dreamoem.com/showthread.php?8313-OpenPLi-4.0-beta-dm800se-by-gjstroom&p=31354&viewfull=1#post31354

gjstroom
01-10-2013, 09:12 PM
gjstroom,
Possible to get the ipk or archive with all files on the driver folder or a link to download them all from your dropbox,


http://sources.dreamboxupdate.com/download/opendreambox/2.0.0/dreambox-dvb-modules/dreambox-dvb-modules-dm800se-3.2-dm800se-20130607.tar.bz2
http://sources.dreamboxupdate.com/download/opendreambox/2.0.0/dreambox-dvb-modules/dreambox-dvb-modules-dm800se-3.2-dm800se-20130927.tar.bz2
http://sources.dreamboxupdate.com/download/opendreambox/2.0.0/dreambox-dvb-modules/dreambox-dvb-modules-dm800se-3.2-dm800se-20131001.tar.bz2

http://sources.dreamboxupdate.com/opendreambox/2.0.3/dm800se/dreambox-dvb-modules_3.2-dm800se-20131001-r7.0-sqsh0_dm800se.ipk

gjstroom
01-10-2013, 09:19 PM
Would it be possible to update from your previous image (based on OE1.6 with 2.6 drivers) to OpenPLI 4.0 by replacing the feeds?
Sort of like a distupgrade.. or did they change the flashmap?
I think you already know the answer... The other question, why in heavens name do you want to do this ?
Make a settings backup, install the new image and restore the settings again.
Exotic plugins don't work on PLi3/4 because of the higher python version, but I don't need to tell you this either...

sunrayfck
01-10-2013, 09:21 PM
Thank you,

But it looks like more to be the 11 July 2012 drivers from here,

http://sources.dreamboxupdate.com/download/opendreambox/2.0.0/dreambox-dvb-modules/dreambox-dvb-modules-dm800se-3.2-dm800se-20120711.tar.bz2

The bcm7405.ko bin file is labelled inside, "version = 20120711"

Looks like more than 1 year old drivers, am I correct ?

Fck


http://sources.dreamboxupdate.com/download/opendreambox/2.0.0/dreambox-dvb-modules/dreambox-dvb-modules-dm800se-3.2-dm800se-20130607.tar.bz2
http://sources.dreamboxupdate.com/download/opendreambox/2.0.0/dreambox-dvb-modules/dreambox-dvb-modules-dm800se-3.2-dm800se-20130927.tar.bz2
http://sources.dreamboxupdate.com/download/opendreambox/2.0.0/dreambox-dvb-modules/dreambox-dvb-modules-dm800se-3.2-dm800se-20131001.tar.bz2

http://sources.dreamboxupdate.com/opendreambox/2.0.3/dm800se/dreambox-dvb-modules_3.2-dm800se-20131001-r7.0-sqsh0_dm800se.ipk

gjstroom
01-10-2013, 09:30 PM
Yes you are correct !
This is also mentioned in the start post: 'drivers: 20130607 (bcm7405.ko date 20120711)'
We currently don't have a newer patched one, we should be pleased with this version...

MastaG
01-10-2013, 11:31 PM
I think you already know the answer... The other question, why in heavens name do you want to do this ?
Make a settings backup, install the new image and restore the settings again.
Exotic plugins don't work on PLi3/4 because of the higher python version, but I don't need to tell you this either...

I know about the plugins..but I have my python decompiler which always comes in handy.
The reason for this is because I'd like to upgrade a few *remote* boxes, and I was hoping I could do it by creating a dirty shell script which takes care of removing obsolete packages/dependencies etc...
And then just reinstall the complete eco-system from the new feeds :P

gjstroom
02-10-2013, 10:43 AM
I know about the plugins..but I have my python decompiler which always comes in handy.
The reason for this is because I'd like to upgrade a few *remote* boxes, and I was hoping I could do it by creating a dirty shell script which takes care of removing obsolete packages/dependencies etc...
And then just reinstall the complete eco-system from the new feeds :P
I think some other ways are possible, with some command line dflash. Do you have telnet/ssh or web access ?

baarsha
02-10-2013, 02:18 PM
Is this only a suitable image for cable tuners or also for satellite tuners
Hans

MastaG
02-10-2013, 03:16 PM
Yes, complete control using reversed ssh tunnels, and remote initscripts which run on each startup.
I think dflash would be a good way to do it, then I only need to prepare the images on my ftp server and let each box wget it and flash it afterwards :)
Good idea!

gjstroom
02-10-2013, 04:55 PM
Is this only a suitable image for cable tuners or also for satellite tuners

All dmm tuners and lots of usb ones are supported.

coco035
02-10-2013, 05:21 PM
thankksssssss

satmru
02-10-2013, 05:42 PM
i cannot install tspanel on this image. any ideas ?

chandra
02-10-2013, 05:54 PM
it works . i remember there is a link few pages back. but i use some other did it thru ftp /tmp

maoui
02-10-2013, 06:47 PM
please
many members tell that the sound AC3+ DONT WORK with this image DONE by ramimaher
can you test this channels sound ??
tf1 hd + france 2 hd in atlantic bird (5west)
or C+ Accion HD (d+ spain) in astra 19 est
is there sound ???

gjstroom
02-10-2013, 08:25 PM
please
many members tell that the sound AC3+ DONT WORK with this image DONE by ramimaher
can you test this channels sound ??
tf1 hd + france 2 hd in atlantic bird (5west)
or C+ Accion HD (d+ spain) in astra 19 est
is there sound ???
Please do some reading instead of asking questions that are already answered.
See http://www.dreamoem.com/showthread.php?8313-OpenPLi-4.0-beta-dm800se-by-gjstroom&p=31232&viewfull=1#post31232

NO YOU CAN NOT GET AC3+ WITH ANY SIM2 CLONE image !
We need the newest drivers and those are not patched yet to work on our SIM2 clones.

gjstroom
02-10-2013, 09:51 PM
Yes, complete control using reversed ssh tunnels, and remote initscripts which run on each startup.
I think dflash would be a good way to do it, then I only need to prepare the images on my ftp server and let each box wget it and flash it afterwards :)
Good idea!
With the writenfi binary from the dflash package installed from the PLi feed it works very simple:


root@dm800se:/media/usb/dflash# ./writenfi openpli-4.0-beta-dm800se-20131002-sim2-ssl84b.nfi
*** raw flash write tool. Don't have unknown bad sectors or it won't work.
*** uncompressing...
*** kernel 3.2-dm800se
*** model dm800se
*** nfi ok!
*** FLASH_GEOM: 0x4000000 0x4000 0x200 0x10 0x5
*** CRC check ignored!
*** stage 0: ..00000000 | 00000008..00000014 (12 bytes)
*** stage 1: ..00040000 | 00000018..0002d408 (185328 bytes)
*** stage 2: ..00400000 | 0002d40c..002f1b8c (2901888 bytes)
*** stage 3: ..04000000 | 002f1b90..02e548b0 (45493536 bytes)
*** bad block list: none
*** writing..
*** partition 1: ..............................
*** partition 2: ..............................................
.................................................. .........
.................................................. .........
.................................................. .........
.................................................. .........
.................................................. .........
.................................................. .........
.................................................. .........
..................... ok!
*** done!

I can't get the nfiwrite binary from the latest Dflash working.

robbyrobby
03-10-2013, 12:42 AM
thanks
1- is there possibility to use barryallen to install this new image in external flach ???


I never use Barry Allen, but from what I have read, it doesn't work.
You can try Flodder. http://www.oozoon-board.de/wbb/index.php?page=Thread&threadID=973&52dbbffb

or dumbo ... is more comfortable (flodder, dumbo, BA ... = same autor Gutemine)

MastaG
03-10-2013, 09:10 AM
With the writenfi binary from the dflash package installed from the PLi feed it works very simple:


root@dm800se:/media/usb/dflash# ./writenfi openpli-4.0-beta-dm800se-20131002-sim2-ssl84b.nfi
*** raw flash write tool. Don't have unknown bad sectors or it won't work.
*** uncompressing...
*** kernel 3.2-dm800se
*** model dm800se
*** nfi ok!
*** FLASH_GEOM: 0x4000000 0x4000 0x200 0x10 0x5
*** CRC check ignored!
*** stage 0: ..00000000 | 00000008..00000014 (12 bytes)
*** stage 1: ..00040000 | 00000018..0002d408 (185328 bytes)
*** stage 2: ..00400000 | 0002d40c..002f1b8c (2901888 bytes)
*** stage 3: ..04000000 | 002f1b90..02e548b0 (45493536 bytes)
*** bad block list: none
*** writing..
*** partition 1: ..............................
*** partition 2: ..............................................
.................................................. .........
.................................................. .........
.................................................. .........
.................................................. .........
.................................................. .........
.................................................. .........
.................................................. .........
..................... ok!
*** done!

I can't get the nfiwrite binary from the latest Dflash working.

Thanks gjstroom, you're the man!
When the new AC3+ driver gets cracked, I'll be creating new images based on your PLi 4.0 build.

btw: Does the nfibackup tool still work on OE2.0?
In OE1.6 I was using mkfs.jffs2 and buildimage

Something like:

DIRECTORY=/media/usbstick
MTDBOOT=2
MTDROOT=3
mkdir -p $DIRECTORY/bi
mkdir -p /tmp/bi/root
mkdir -p /tmp/bi/boot
mount -t jffs2 /dev/mtdblock/$MTDROOT /tmp/bi/root
mount -t jffs2 /dev/mtdblock/$MTDBOOT /tmp/bi/boot
echo "Bezig met maken van image..."
echo "boot.jffs2"
mkfs.jffs2 --root=/tmp/bi/boot --faketime --output=$DIRECTORY/bi/boot.jffs2 --eraseblock=0x4000 -n -l
echo "root.jffs2"
mkfs.jffs2 --root=/tmp/bi/root --faketime --output=$DIRECTORY/bi/root.jffs2 --eraseblock=0x4000 -n -l
# SSL for dm800 and dm800se is already gzipped.
cp /etc/ssl84b.bin $DIRECTORY/bi/main.bin.gz
echo "Building image..."
/usr/sbin/buildimage $DIRECTORY/bi/main.bin.gz $DIRECTORY/bi/boot.jffs2 $DIRECTORY/bi/root.jffs2 dm800se 64 > $DIRECTORY/image.nfi
echo "Opruimen..."
sync
umount /tmp/bi/root
umount /tmp/bi/boot
rm -rf /tmp/bi
rm -rf $DIRECTORY/bi

Matrex
04-10-2013, 03:13 AM
Is there any flash backup utility that works with this image? I tried dflash but the image it saves is a massive 70gb and wont reflash back on the box, nfiflash also does not seem to work.

If I was to use software management to back up cams and plugins I have added does anyone know exactly what files need to be backed up?

nerosiz
04-10-2013, 10:09 AM
Did not I try this Baryallen this image How to load which runs version

alex873
04-10-2013, 03:51 PM
Hi gjstroom

can we use JTR plugin to convert this image to UBIFS?

I install enigma2-plugin-extensions-jtr_0.6.0_all.ipk but after configure i try to backup without success.

Regards.

gjstroom
04-10-2013, 08:01 PM
can we use JTR plugin to convert this image to UBIFS?
I install enigma2-plugin-extensions-jtr_0.6.0_all.ipk but after configure i try to backup without success.

See this topic on the OpenPli forum http://openpli.org/forums/topic/28374-jack-the-ripper-pli-special-edition-for-ubifs-conversion-of-pli-oe-30-images/
Mr Gutemine likes to put all kinds of timebombs in his creations, most likely that's why it doesn't work. There's also a enigma2-plugin-extensions-jtr_0.6.3_all.ipk, maybe try that one. I did use it with success some months ago.
It also should be possible to convert dflash backups to ubifs, but if it works for OpenPLi ???
Also keep in mind you end up with almost no free available flash memory. You gain some boot seconds, but that's all.

alex873
04-10-2013, 10:17 PM
Thanks gjstroom.

Seems JTR was only for a test and now ends his trial time.

I wish to try UBIFS because before backup with dflash i have

/dev/root 60.0M 45.1M 14.9M 75% /

but after restore image from bootloader i lost all free space.

I need to delete files manually to make image work again.

Regards

biohazard
05-10-2013, 01:07 AM
No, I only make clean images. You can download the cccam plugin yourself, just go to Menu - Plugins - Download plugins (green button) - softcams

Downloaded mgcamd 1.35 from menu but unable to install due to cannot satisfy dependencies libcrypto 0.98. Need help on this.

jerry
05-10-2013, 01:45 AM
Downloaded mgcamd 1.35 from menu but unable to install due to cannot satisfy dependencies libcrypto 0.98. Need help on this.
Try to unplug power then retry download

biohazard
05-10-2013, 07:14 AM
Try to unplug power then retry download

Download is possible but unable to install as it cannot satisfy the libcrypto 0.98 dependencies.

jerry
05-10-2013, 11:39 AM
I was trying to install TSMedia oe1.6, but I got error "Bad magic number".
I tried TSMedia oe2, it was installed but no channel worked.

Which plugins to use 1.6 or 2?
Thanks

gjstroom
05-10-2013, 11:40 AM
Try to unplug power then retry download
Haha that will help...


Download is possible but unable to install as it cannot satisfy the libcrypto 0.98 dependencies.
This is an OpenPli issue, because it's running a newer version of libcrypto (1.0.0) and libssl (1.0.0).
Have a look here, you can download the enigma2-plugin-softcams-mgcamd_1.35a-ssl1.0_mipsel.ipk and enigma2-plugin-softcams-mgcamd_1.38c-ssl1.0_mipsel.ipk.
http://openpli.org/forums/topic/30628-mgcamd-for-pli-40-littlesat/?hl=mgcamd
They are trying to put in in the feed, but it looks like they didn't succeed yet...

This also is a solution to use the current mgcamd:


cd /tmp
wget http://downloads.pli-images.org/feeds/openpli-3.0/dm800se/mips32el/libcrypto0.9.8_0.9.8x-r15.0_mips32el.ipk
wget http://downloads.pli-images.org/feeds/openpli-3.0/dm800se/mips32el/libssl0.9.8_0.9.8x-r15.0_mips32el.ipk
wget http://downloads.pli-images.org/feeds/openpli-3.0/dm800se/all/libcrypto-compat_0.9.7-r4_all.ipk
opkg install libcrypto0.9.8_0.9.8x-r15.0_mips32el.ipk
opkg install libssl0.9.8_0.9.8x-r15.0_mips32el.ipk
opkg install libcrypto-compat_0.9.7-r4_all.ipk
opkg install enigma2-plugin-softcams-mgcamd

jerry
05-10-2013, 04:03 PM
Haha that will help...



Cccam gave me the same error before powering off

biohazard
06-10-2013, 04:24 AM
This is an OpenPli issue, because it's running a newer version of libcrypto (1.0.0) and libssl (1.0.0).
Have a look here, you can download the enigma2-plugin-softcams-mgcamd_1.35a-ssl1.0_mipsel.ipk and enigma2-plugin-softcams-mgcamd_1.38c-ssl1.0_mipsel.ipk.
http://openpli.org/forums/topic/30628-mgcamd-for-pli-40-littlesat/?hl=mgcamd
They are trying to put in in the feed, but it looks like they didn't succeed yet...

This also is a solution to use the current mgcamd:


cd /tmp
wget http://downloads.pli-images.org/feeds/openpli-3.0/dm800se/mips32el/libcrypto0.9.8_0.9.8x-r15.0_mips32el.ipk
wget http://downloads.pli-images.org/feeds/openpli-3.0/dm800se/mips32el/libssl0.9.8_0.9.8x-r15.0_mips32el.ipk
wget http://downloads.pli-images.org/feeds/openpli-3.0/dm800se/all/libcrypto-compat_0.9.7-r4_all.ipk
opkg install libcrypto0.9.8_0.9.8x-r15.0_mips32el.ipk
opkg install libssl0.9.8_0.9.8x-r15.0_mips32el.ipk
opkg install libcrypto-compat_0.9.7-r4_all.ipk
opkg install enigma2-plugin-softcams-mgcamd


Do you have any other alternatives for the download as i need to create an account before i am able to download it. Second solution does install the sofcam but would not clear the channels. Is it due to the libcrypto 0.98 being used instead of the latest one?

jerry
06-10-2013, 10:49 AM
Which plugins to use 1.6 or 2?
Thanks

gjstroom
06-10-2013, 11:25 AM
Which plugins to use 1.6 or 2?
You need OE2.0 plugins. It's a little confusing, there's no good definition of OE2.0.
OE2.0 should have (in my opinion) kernel 3.2, pyhton 2.7 and the closed source Enigma2 of DMM, OpenPLi has all, except they are using their on branch (opensource) op Enigma2.
Plugins depend the most on the Python version used.

gjstroom
06-10-2013, 11:27 AM
Do you have any other alternatives for the download as i need to create an account before i am able to download it. Second solution does install the sofcam but would not clear the channels. Is it due to the libcrypto 0.98 being used instead of the latest one?
The ones you can download from the Pli forum are simply binary edited ones, they changed the lib version numbers inside the binary. I don't think your problem has any link with the libraries.
As for the download, create an account, I am not a proxy !

I did some new investigation and discovered libcrypto-compat is nothing more than some additional links to libcrypto and libssl.
It looks there's only a dependency with libcrypto0.9.8.


If you already installed the older libraries unintall them first:

opkg remove enigma2-plugin-softcams-mgcamd
opkg remove libcrypto-compat
opkg remove libssl0.9.8
opkg remove libcrypto0.9.8

cd /lib
ln -s libcrypto.so.1.0.0 libcrypto.so.0.9.8
opkg --force-depends install enigma2-plugin-softcams-mgcamd

you can ignore the 'satisfy_dependencies_for' lines


result:


rroot@dm800se:/# mgcamd
tuxbox mgcamd v1.35a by mixvt (compiled Jan 26 2010 15:59:20)
[mg] Net:33:7:2:5s Show ecm:1, emm:1 Up:1 Au:2 Dir:0 Osd:no:80:0 Cache:7 Log:3:172.16.1.1:28007 Reread:0
[mg] Ecm cache time: 15
Box type: mips dreambox (dm7025, dm800)


Don't forget to set B: { 06 } in mg_cfg (thanks to chiefobrei)
Delete all newcamd.list* and mg_cfg* from /etc/tuxbox/config. All config files are located in /var/keys.

HibbyDave
06-10-2013, 03:41 PM
gjstroom great work as always, one slight problem I have, when I switch off the wd live tv box it's also switching off the dm800se box, is there any way to change the receiver frequency on the dm800se?

gjstroom
06-10-2013, 03:55 PM
gjstroom great work as always, one slight problem I have, when I switch off the wd live tv box it's also switching off the dm800se box, is there any way to change the receiver frequency on the dm800se?
I never got it to work, I have multiple boxes and they all respond to the remote.
I just found this, give it a try.
http://www.digital-kaos.co.uk/forums/f39/change-your-dream-remote-code-4-different-boxes-123943/
http://openpli.org/forums/topic/26586-multi-remote-control-layer-plugin/
It look like this doesn't work for the black remotes.

chiefobrei
06-10-2013, 05:11 PM
root@dm800se:/# mgcamd
tuxbox mgcamd v1.35a by mixvt (compiled Jan 26 2010 15:59:20)
[mg] Net:1:7:0:5s Show ecm:1, emm:1 Up:1 Au:2 Dir:0 Osd:no:80:0 Cache:7 Log:3:172.16.1.1:28007 Reread:0
[mg] Ecm cache time: 15
Box type: dbox2


I did try several mgcamd binaries and see it's decoding but no picture...

Have you set the boxtype im mg.cfg?

B: { 06 }

jerry
06-10-2013, 05:21 PM
It works very nicely
Thanks for all your work

amir8695
06-10-2013, 05:24 PM
HELLO BRO I CHANGE BCM7405 CHANGE VERSION AND AFTER ALL UPDATE IMGE IS GOOD WORK. BUT TODAY 6-10-2013 I UPDATE AFTER REBOOT SAME PROBLEM COME BACK HELP.....Fix if you already did a update without editing the 'status' file
Code:
cd /lib/modules/3.2-dm800se/extra
rm bcm7405.ko
wget http://dl.dropboxusercontent.com/u/9860949/dm800se/bcm7405.ko
reboot..........WHER I GO IN DCC I DONOT KNOW HOW FIX... THANK

talbs
06-10-2013, 05:51 PM
In DCC, go in telnet window and write each following line on after this other.

cd /lib/modules/3.2-dm800se/extra
rm bcm7405.ko
wget http://dl.dropboxusercontent.com/u/9860949/dm800se/bcm7405.ko
reboot

that's all!

gjstroom
06-10-2013, 07:02 PM
Have you set the boxtype im mg.cfg?
B: { 06 }
Yep, thanks ! Nice those programs with limited documentation...
according the example:
# box type
# 00 autodetect, change only if you think wrong type detected.
# 01 dbox2
# 02 dreambox
# 03 triple-dragon
# 04 relook
# 05 openbox
B: { 00 }

amir8695
06-10-2013, 09:13 PM
Thanks bor quick help all ok

LichtiMC
07-10-2013, 07:57 AM
New image in start post, this one has for all dvb-modules the version set to 3.2-21130927-r7.0. So that's 100 years in the future ! No more driver update problems in the near future (I hope...).
Could you also fix the OpenPLI 3.0 image? As I see it's still the original image (20130928) ...


gjstroom great work as always, one slight problem I have, when I switch off the wd live tv box it's also switching off the dm800se box, is there any way to change the receiver frequency on the dm800se?
Did you also consider the (new function) HDMI CEC? Just a guess, but maybe this is your problem...!? Try deactivating it from the plugins menu...

gjstroom
07-10-2013, 04:46 PM
Could you also fix the OpenPLI 3.0 image? As I see it's still the original image (20130928) ...
Yes, can do, but I think the majority will use the PLi 4.0 image. I will introduce dailybuilds in a few days.



Did you also consider the (new function) HDMI CEC? Just a guess, but maybe this is your problem...!? Try deactivating it from the plugins menu...
I don't think the dreambox is connected to his WD mediaplayer. To my knowledge hdmi cec only works from device to tv, not from device to tv to other device.
And I also think a WD mediaplayer doesn't supports hdmi cec at all, but that's pure speculation.

HibbyDave
07-10-2013, 05:14 PM
nice one mate that worked a treat.

pepino
07-10-2013, 11:25 PM
@gjstroom

# box type
# 00 autodetect, change only if you think wrong type detected.
# 01 dbox2
# 02 dreambox
# 03 triple-dragon
# 04 relook
# 05 openbox
# 06 dreambox/mips
# 08 stapi/kathrein
# 09 stapi/ipbox
# 11 stapi/openbox
# 12 dgs based image/cuberevo-ipbox
B: { 06 }

talbs
08-10-2013, 03:02 PM
Hi,

When controlling the box from WEBIF, the VOl+/VOL- buttons behavior are inverted.

This is just a remark as i was trying to increase volume remotely and it stucks at 0.
I thought that i had an issue with my box lol

++

dream778
08-10-2013, 10:30 PM
thank's a lot for this wonderful image,i feeling sad cause our dm800se sim2.10 does'nt support the AC3+ and other boxes do this but after hearing that i'm very glad,just a question : AC3+ will work on our boxes sim2.10 just with a driver for openpli if that patched by team sim2 ? or for other images patched OE2 will be support AC3+ too or not ?

chiefobrei
09-10-2013, 06:57 AM
yes, you have to wait for a patched driver.

BravoNyN
09-10-2013, 05:17 PM
Yesterday i went from 2.1 to 4.0 and now my c line does not work anymore ..

is it CCcam.cfg related server related or CCcam itself that needs different software..
hope you can tell me

thnx :D

johny48
09-10-2013, 05:49 PM
Yesterday i went from 2.1 to 4.0 and now my c line does not work anymore ..

is it CCcam.cfg related server related or CCcam itself that needs different software..
hope you can tell me

thnx :D
Hi m8
try unplugging your box and do a hard reboot that worked for me

BravoNyN
09-10-2013, 07:11 PM
Hi m8
try unplugging your box and do a hard reboot that worked for me

tried it with no luck
maybe i should reinstall cam .. but no idea wich ?

BravoNyN
09-10-2013, 08:26 PM
stuck between a rock and a hardplace now ..
i decided to get back to my old version .. but now i have no softcam at all
and no way to download one

tried the 2.1 the 3 and the 4 version..
i think the C server is down

but is there a way to test if the CCcam.cfg is configured correctly ?

gjstroom
09-10-2013, 09:39 PM
stuck between a rock and a hardplace now ..
i decided to get back to my old version .. but now i have no softcam at all
and no way to download one

tried the 2.1 the 3 and the 4 version..
i think the C server is down

but is there a way to test if the CCcam.cfg is configured correctly ?
CCcam is the same binary on all older PLi versions.
Open a telnet session
type: ps |grep -i cccam
type: killall CCcam (maybe add a version no, depends on the result above)
type cccam -d (now you can see the cccam log in the telnet session)

BravoNyN
09-10-2013, 10:17 PM
23:16:25.713 CCcam: starting CCcam 2.3.0 compiled on Dec 15 2011@23:38:08
23:16:25.714 CCcam: ================================================== ==========
==========
23:16:25.714 CCcam: online using nodeId 2e5a99a72e8bed06
23:16:25.721 CCcam: dvb api3 detected
23:16:25.722 CCcam: DM8000 detected
23:16:25.722 CCcam: create 8 cam device(s)
23:16:28.473 CCcam: irdeto card found
23:16:30.662 CCcam: card added to broker with caid 604
23:16:30.880 CCcam: readKeyfile: cannot open /var/keys/SoftCam.Key or not found
23:16:30.880 CCcam: readKeyfile: cannot open /var/keys/AutoRoll.Key or not found
23:16:30.880 CCcam: static cw not found or bad
23:16:30.881 CCcam: parsed 0 entries from /var/keys/CCcam.prio
23:16:30.881 CCcam: readProviderfile: cannot open /var/etc/CCcam.providers or no
t found
23:16:30.881 CCcam: readChannelList: cannot open /var/etc/CCcam.channelinfo or n
ot found
23:16:30.882 CCcam: server started on port 12000
23:16:36.920 CCcam: cam[0] set PMT for sid=c9
23:16:36.921 CCcam: start EMM
23:16:37.117 CCcam: EMM demux 1 set
23:16:37.118 CCcam: EMM: start filter on irdeto emmpid: 0x41c caid: 0x604 id: 0x0

alex873
09-10-2013, 10:43 PM
23:16:25.713 CCcam: starting CCcam 2.3.0 compiled on Dec 15 2011@23:38:08
23:16:25.714 CCcam: ================================================== ==========
==========
23:16:25.714 CCcam: online using nodeId 2e5a99a72e8bed06
23:16:25.721 CCcam: dvb api3 detected
23:16:25.722 CCcam: DM8000 detected
23:16:25.722 CCcam: create 8 cam device(s)
23:16:28.473 CCcam: irdeto card found
23:16:30.662 CCcam: card added to broker with caid 604
23:16:30.880 CCcam: readKeyfile: cannot open /var/keys/SoftCam.Key or not found
23:16:30.880 CCcam: readKeyfile: cannot open /var/keys/AutoRoll.Key or not found
23:16:30.880 CCcam: static cw not found or bad
23:16:30.881 CCcam: parsed 0 entries from /var/keys/CCcam.prio
23:16:30.881 CCcam: readProviderfile: cannot open /var/etc/CCcam.providers or no
t found
23:16:30.881 CCcam: readChannelList: cannot open /var/etc/CCcam.channelinfo or n
ot found
23:16:30.882 CCcam: server started on port 12000
23:16:36.920 CCcam: cam[0] set PMT for sid=c9
23:16:36.921 CCcam: start EMM
23:16:37.117 CCcam: EMM demux 1 set
23:16:37.118 CCcam: EMM: start filter on irdeto emmpid: 0x41c caid: 0x604 id: 0x0

cccam seems to work fine i see you have irdeto card, to works fine you must configure CAMKEY & CAMDATA section in /etc/cccam.cfg

check your old config.

if you use cccam server you can check server state typing on browser:

ipdreambox:16001 to see CCcam info pages

# overrule the irdeto camkey (8 byte hex), default 11 22 33 44 55 66 77 88
#
# CAMKEY: <device> <byte1> <byte2> <byte3> <byte4> <byte5> <byte6> <byte7> <byte8>
#
#example
#
#CAMKEY: /dev/sci0 11 22 33 44 55 66 77 88

# overrule the irdeto camdata (64 byte hex)
# trailing zero bytes can be omitted
# default for unknown ASC's is 11 22 33 44 55 66 77 88 00 00 .. 00, known ASC's have other defaults
#
# CAMDATA: <device> <byte1> <byte2> <byte3> <byte4> <byte5> <byte6> ... <byte64>
#
#example, when only the first 15 camdata bytes are nonzero
#
#CAMDATA: /dev/sci0 11 22 33 44 55 66 77 88 99 aa bb cc dd ee ff

Regards.

talbs
10-10-2013, 10:50 AM
Hello,

Can someone advise which tool can be used to do a safe backup of my openPli4 image?

If an .ipk file can be posted it would be nice.

Thank you

biohazard
10-10-2013, 12:42 PM
Hello,

Can someone advise which tool can be used to do a safe backup of my openPli4 image?

If an .ipk file can be posted it would be nice.

Thank you

U can try dflash plugin v9.36.

gjstroom
10-10-2013, 08:17 PM
I added a daily build download link to start post !

chandra
10-10-2013, 09:09 PM
Thanks for the update;
So can i do an online update stright from my box as i am on build 'OpenPLi-4.0-beta-dm800se-20130930-sim2'.

Thanks again,

gjstroom
10-10-2013, 09:37 PM
Thanks for the update;
So can i do an online update stright from my box as i am on build 'OpenPLi-4.0-beta-dm800se-20130930-sim2'.

Online updates were already possible.

Haroon
11-10-2013, 09:17 AM
Anybody noticed PQ deterioration in PLI 4. At least I have, PQ not as good 2.1 or 3.0.

Reverted back to 3.0.

gjstroom
11-10-2013, 12:10 PM
Anybody noticed PQ deterioration in PLI 4. At least I have, PQ not as good 2.1 or 3.0.
Reverted back to 3.0.
Please explain PQ ???
Pli3.0 is almost the same asPLi4.0, it's build in a newer build environment and uses an newer version of libcrypto and libssl.

talbs
11-10-2013, 01:39 PM
PQ means picture quality.
Unless i'm wrong :-)

chandra
11-10-2013, 04:14 PM
May be my view, for me i du not feel anything low. I was on 2.1 and now on 4.
never tried 3 anyway..

ayaztgi
11-10-2013, 05:04 PM
Anybody noticed PQ deterioration in PLI 4. At least I have, PQ not as good 2.1 or 3.0.

Reverted back to 3.0.

It is strange, I feel the picture quality got improved with the Openpli 4.0 image, a bit more sharp and contrasty. I too switched from version 2.1.

illi79
12-10-2013, 11:13 AM
I was wondering if I could install this image on mu Sunray SR4? When its possible will the triple tuner work? or do I have to install the drivers for that? And in general can I install any DM800se image on my SR4? Thanks in advance

gjstroom
12-10-2013, 11:50 AM
Yes you can run it on your SR4, for triple tuner config look here: http://www.dreamoem.com/showthread.php?6068-Help-with-sunray4&highlight=trialtuner

Jigs24x7
12-10-2013, 03:35 PM
Anybody noticed PQ deterioration in PLI 4. At least I have, PQ not as good 2.1 or 3.0.

Reverted back to 3.0.

yes dear Agree with you picture quality is not fine some time up some time down and one more thing, in my side in Pli.4.0 USB not working and not showing plz help and also tspanel not find anywhere in plugins (Extensions)

chandra
12-10-2013, 07:22 PM
i just tried USB for first time for you to give a feedback and it just works straight away. just plugged in and rebooted.
See screenshot.
also TSP is fine and a dl link was provided by another m8 on same thread, just roll back to few pages.

In my view if you get intermittent issues2323 with signal very unlikely due to the image issue , just recheck upto tuner settings..

gjstroom
12-10-2013, 10:27 PM
yes dear Agree with you picture quality is not fine some time up some time down and one more thing, in my side in Pli.4.0 USB not working and not showing plz help and also tspanel not find anywhere in plugins (Extensions)
Pli 3 and 4 use the same enigma2 and drivers I think it's between your ears.
tspanel is not available in original Pli feeds.... Install from other source.

Jigs24x7
13-10-2013, 03:13 AM
ok i'll check and reply to you

Jigs24x7
13-10-2013, 04:51 AM
use the tspanel here
http://www.dreamoem.com/showthread.php?8313-OpenPLi-4.0-beta-dm800se-by-gjstroom&p=31354&viewfull=1#post31354

ok i download the TSpanel but how to enter through dcc plz help

gjstroom
13-10-2013, 08:27 AM
ok i download the TSpanel but how to enter through dcc plz help
Do some searching your own, we are not a kindergarten !
http://lmgtfy.com/?q=openpli+manual+install+ipk&l=1
Please stop posting in BOLD or other Colors and edit your own post if you want to add something when there's no newer reply.

anoir
13-10-2013, 01:52 PM
Hi peeps.
I also switched from 2.1 to 4.0.
it works Fine! only bugg i found is the Mediaplayer.
While watching movies (streaming from NAS) it stops working after watching for 30min. the dreambox then stops working (or updating) i don't know en then restarts.
it happend now every movie i watched. Somebody else having this problem?
thanks!

Jigs24x7
13-10-2013, 03:21 PM
Do some searching your own, we are not a kindergarten !
http://lmgtfy.com/?q=openpli+manual+install+ipk&l=1
Please stop posting in BOLD or other Colors and edit your own post if you want to add something when there's no newer reply.

agree with you next time i will

uscool
13-10-2013, 05:44 PM
Hi, thanks for this i got everything working, just cannot install TSmedia, comes up with this error

2327

any help ? , i tried a few and also tried installing from TSpanel :(

Thanks

uscool
13-10-2013, 07:15 PM
its ok, daily build it doesn't seem to install on but tried the older one and it worked

baarsha
13-10-2013, 07:54 PM
He is working fine.
Thanks

gjstroom
13-10-2013, 08:50 PM
its ok, daily build it doesn't seem to install on but tried the older one and it worked
No problem here. Maybe a powercycle after flashing helps...

Satkees
14-10-2013, 03:47 PM
Hi peeps.
I also switched from 2.1 to 4.0.
it works Fine! only bugg i found is the Mediaplayer.
While watching movies (streaming from NAS) it stops working after watching for 30min. the dreambox then stops working (or updating) i don't know en then restarts.
it happend now every movie i watched. Somebody else having this problem?
thanks!

I have same problem , movie playing stops and picture starts hanging and wheels turning , then box stops playing and i must reboot whit power switch.

regards

Satkees
14-10-2013, 05:52 PM
I have same problem , movie playing stops and picture starts hanging and wheels turning , then box stops playing and i must reboot whit power switch.

crashlog.....

regards

main thread is non-idle! display spinner!
poll: unhandled POLLERR/HUP/NVAL for fd 62(16)
ERROR reading PES (fd=53) - Value too large for defined data type
poll: unhandled POLLERR/HUP/NVAL for fd 53(8)

regards

evgeny
14-10-2013, 07:39 PM
I have same problem , movie playing stops and picture starts hanging and wheels turning , then box stops playing and i must reboot whit power switch.

regards

Same problem, only after ~10min

Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.706000] audio_cdb_itb_error_isr: 30 callbacks suppressed
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.706000] audio_cdb_itb_error_isr! underflow
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.738000] audio_cdb_itb_error_isr! underflow
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.770000] audio_cdb_itb_error_isr! underflow
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.789000] subqueue:src invoked oom-killer: gfp_mask=0x201da, order=0, oom_adj=0, oom_score_adj=0
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.789000] Call Trace:
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.789000] [<803dab78>] dump_stack+0x8/0x34
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.789000] [<80082764>] dump_header.isra.10+0x84/0x1a0
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.789000] [<80082a70>] oom_kill_process.constprop.15+0xb4/0x2a4
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.789000] [<800830c0>] out_of_memory+0x2a4/0x3a4
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.789000] [<800866bc>] __alloc_pages_nodemask+0x660/0x674
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.789000] [<800819e8>] filemap_fault+0x208/0x488
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.789000] [<8009b798>] __do_fault+0x8c/0x4fc
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.789000] [<8009eb98>] handle_pte_fault+0xa0/0x89c
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.790000] [<8009f428>] handle_mm_fault+0x94/0xf0
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.790000] [<8000e860>] do_page_fault+0x110/0x3c0
Oct 7 22:50:39 dm800se user.warn kernel: [ 5016.790000] [<80004760>] ret_from_exception+0x0/0x28

Oct 7 22:50:39 dm800se user.err kernel: [ 5016.800000] Out of memory: Kill process 4159 (enigma2) score 750 or sacrifice child
Oct 7 22:50:39 dm800se user.err kernel: [ 5016.801000] Killed process 4159 (enigma2) total-vm:264948kB, anon-rss:105908kB, file-rss:44kB

gjstroom
14-10-2013, 08:48 PM
The older driver is most probably causing this fault. It's not fixable unless we get a newer patched driver.

joost
16-10-2013, 04:42 PM
Hi peops.

First many thanks to the the sim2.1 team to make this possible.

Thumbs up. :-)

This image is great "only tested half a day" everyting works.
extra hardware
1.dvb-t stick pinnacle 72e
2.wifi stick r8712
3 mkv working with down mix dts and ac3.

Tested mkv files from nas with dts and no erro's at all
playtime 82 minutes with out hiccups and no erro's or reboots.

greatings

DM800SE
16-10-2013, 11:32 PM
I confirm with this image, if you put the AC3+ downmix OFF, audio AC3+ works and is heard.

jpg-93
17-10-2013, 09:19 AM
Hi all
I use this very good and spedy image on my DM800SE HD clone.
I had a little problem with the emus (CCcams 221 & 230) and my off cards (TNTsat & Csat France) whichs hangs if i change channels after a long tine on the same channel.
my local address server (127.0.0.1) seems inactive (red) and the emu don't restart even restarting emu (by several methods) or restarting lan or change to another emu (oscam or scam). The only way is the full restart.
Have somebody an solution ?
Many Thks

gjstroom
17-10-2013, 09:13 PM
I have the same problem. When you install oscam in a fresh image the only way to get it working is doing a reboot. I have no solution for it, try the PLi forum.

Douglas-v
20-10-2013, 11:53 AM
gjstroom
No complains hear, I must say that this works great on every level. I have noticed that the usb-pen disipear from the dreambox time to time. Only to restart the box and it works again.
Many many thanks for a great jobb to all of those who have made this work for us.
Have a great day..:)

gjstroom
20-10-2013, 03:26 PM
gjstroom
No complains hear, I must say that this works great on every level. I have noticed that the usb-pen disipear from the dreambox time to time. Only to restart the box and it works again.
Many many thanks for a great jobb to all of those who have made this work for us.
Have a great day..:)
It may also be a problem with your usb-pen. Try to run a fsck on your usb-pen.


umount /media/usb
fsck.extY /dev/sdZ1

where Y= 3 or 4 depends how it's formatted and Z is a or b depends if you have a internal hdd (in that case it's b).

chandra
20-10-2013, 04:45 PM
fyi; recently i started using a USB stick to store my EPG data &Picons from my HDD. Never had any issues
I used gparted to format the USB anyway.

viktorw
20-10-2013, 05:47 PM
is there a possibility to get hbbtv on dmm800se clone? because i can't find anything

gjstroom
20-10-2013, 06:30 PM
is there a possibility to get hbbtv on dmm800se clone? because i can't find anything
no, hbbtv requires closed source components which are not available for OpenPli.

viktorw
20-10-2013, 07:13 PM
or is this on other new image oe2.0 releases availible?

LichtiMC
21-10-2013, 10:45 AM
New images of ramiMAHER have drivers of 01.10.2013 included... and ssbl 84c ...
Does this mean, drivers are patched finally? And if yes, are they included in your dailybuild images automatically?
Thanks a lot for your work!
Kind regards,
David

mfaraj57
21-10-2013, 10:54 AM
New images of ramiMAHER have drivers of 01.10.2013 included... and ssbl 84c ...
Does this mean, drivers are patched finally? And if yes, are they included in your dailybuild images automatically?
Thanks a lot for your work!
Kind regards,
David
The driver is original and not patched but the loader is new as well as modified enigma for dmm image
sure gjstroom will use original drivers and new ssl on his builds

Aliraza63
21-10-2013, 11:10 AM
Kindly give me the link of Open Pli 4.0 gjstroom build sim 2 image with ssl84C

Bassie
21-10-2013, 12:27 PM
Gjstroom said yesterday:

"For some strange reason this SSL doesn't work for OpenPLi with all original 20131001 drivers. The Newnigma2 image uses squashfs drivers, maybe that's the reason ?"

But offcourse he's working on it :)

LichtiMC
21-10-2013, 03:09 PM
Pls. help me out with following misunderstanding:

I thought with drivers from 20130927 we would loose tuner / bootlogo, because they are not patched yet...
But now there's already driver 20131001? How does this work?

Thank you very much...

michalsw
21-10-2013, 03:45 PM
Had some minor issues to start off with, but they were down to my configuration.

All working briliant, thanks gjstroom.

Bassie
21-10-2013, 04:05 PM
Try use OScam, its a cam problem not a image problem.

Bassie
21-10-2013, 04:07 PM
Pls. help me out with following misunderstanding:

I thought with drivers from 20130927 we would loose tuner / bootlogo, because they are not patched yet...
But now there's already driver 20131001? How does this work?

Thank you very much...

Sim2 boxes can either use a patched ssl to get rid of the driver protection or the driver itself must be patched.

Last time the (old) driver was patched, now its the ssl.

Nothing to worry for you it will be all included in the images.

dream778
21-10-2013, 04:34 PM
hi bassies can we use this driver as ipkg install with old image as oe1.6 to have ac3+ or this drivers is making just for images oe2.0?

Bassie
21-10-2013, 04:40 PM
OE 1.6 is on 2.6 kernel OE 2.0 on 3.x so no cannot work, sorry..

gjstroom
21-10-2013, 05:08 PM
Kindly give me the link of Open Pli 4.0 gjstroom build sim 2 image with ssl84C
At the moment the new SSL doesn't work for OpenPLi and the latest drivers.
The only explanation I can give is, the other working ssl84c images have the drivers in a squashfs filesystem. OpenPli doesn't use this technique.
I will try to make a OpenPLi with squashfs support in kernel and test if this works.

LichtiMC
21-10-2013, 06:30 PM
Sim2 boxes can either use a patched ssl to get rid of the driver protection or the driver itself must be patched.

Last time the (old) driver was patched, now its the ssl.

Nothing to worry for you it will be all included in the images.

I'm very interested in this topic, so thank you really for answering my questions. :-)
And I've got one more... ;-)

If it's possible to circumvent driver protection by a patched ssl, I guess this is the more flexible solution? Or has the ssl to be patched over and over again when a new set of drivers comes out?

Bassie
21-10-2013, 06:39 PM
Yes or the drivers there choice..

gjstroom
21-10-2013, 10:41 PM
At the bottom of the start post you can find the link to download OpenPLi-4.0-beta-dm800se-sim2-84c !

All original 20131001 drivers inside, I had to make some kernel adjustments to get it working with the new SSL #84C.

Daily build will follow !!!

jerry
21-10-2013, 10:53 PM
Sorry for the newbie questions, but what is SSL #84C?
How do I know which to use?
Thanks

Bassie
21-10-2013, 10:58 PM
Sorry for the newbie questions, but what is SSL #84C?
How do I know which to use?
Thanks

SSL 84b Supports org driver 20111109 for OE 1.6 2.6.x kernel and patched driver 20120711 for OE 2.0 3.x kernel.

SSL 84c Supports org driver 20131001 for OE 2.0 3.x kernel.

You just use the newest Pli very simple :)

jerry
22-10-2013, 02:09 AM
Thank you so much!

dream778
22-10-2013, 02:23 AM
AC3+ don't work with me in openpli4.0 ssl84c.

Aliraza63
22-10-2013, 05:49 AM
gjstroom Thanks for ur hard work . Kindly give any other link this download link stops downloading after 27%

MastaG
22-10-2013, 09:40 AM
At the bottom of the start post you can find the link to download OpenPLi-4.0-beta-dm800se-sim2-84c !

All original 20131001 drivers inside, I had to make some kernel adjustments to get it working with the new SSL #84C.

Daily build will follow !!!

What did you change to make the new 84C bootloader work?

LichtiMC
22-10-2013, 10:17 AM
OpenPli doesn't like Dreamboxes anymore... :(
Click here (http://openpli.org/news/openpli-stops-actively-supporting-dream-multimedia-stbs/) for the full article...


The Dream Multimedia hardware currently supported by OpenPLi will remain active in our automated build environment, which means images will be generated and feeds will remain available, until we get to a point that this is no longer possible without intervention. At that point, we will effectively stop with all support.

Does anybody have an idea what will be then? Is this the end of it...?

In addition gutemine of ozoon-board stopped support of his enigma2 plugin dflash (http://openpli.org/forums/topic/30936-openpli-stops-actively-supporting-dream-multimedia-stbs/#entry381655) (announcement on his plugin-thread) (http://www.oozoon-board.de/wbb/index.php?page=Thread&postID=21845#post21845) because of this... yippi-yeahh... :mad:

viktorw
22-10-2013, 01:45 PM
Is there a working multiboot Tool or flashexpander like flashexpander or freeze?

Bassie
22-10-2013, 02:17 PM
OpenPli doesn't like Dreamboxes anymore... :(
Click here (http://openpli.org/news/openpli-stops-actively-supporting-dream-multimedia-stbs/) for the full article...
Does anybody have an idea what will be then? Is this the end of it...?


Its a good question nobody can answer right now, it means when a fuqup* happens they will not solve it and if its a very big h0rr0r bug they will freeze the build+feeds.

*fuqup history shows what did happen the last months:

Some stuff commited for other boxes, result streaming broken for dmm.
" ", result USB DVB Tuners freeze show wrong freq on dmm boxes.
Some stuff commited to optimze png and bla, result png picons wrong displayed on dmm boxes.
Some stuff commited to optimze skins, result artifacts, menu items dissapeared on dmm boxes.

Stuff like that :) and it will not be fixed anymore...

Normally Pli cycles arround 1 year with a new release so when Pli 5.0 will be out in 2015 all dreambox support will be gone.

Its up to great hobby people to build further and produce patches/workarrounds for bugs, as Pli also reccomends its open source :)

Bassie
22-10-2013, 02:26 PM
One example and based on pli decision to stop dmm ect is not to fix ac3+ for dmm -
http://openpli.org/forums/topic/30392-dd/page-6#entry380729

Overhere Goodsat did fix it in e2 thanks for that :)

dream778
22-10-2013, 02:27 PM
that's mean no longer support for dmm boxes,why this decision now? and what consequence assume the user's of dmm boxes with abondon support of openpli?

dream778
22-10-2013, 02:29 PM
Franckly i think this is caused by war between the producers of boxes.and the final users is the victime.

snakemetal
22-10-2013, 03:18 PM
Hi can i just ask a noob question
What advantage is there in using original 20131001 driver with SSL84C over patched driver 20120711 with SSL84B?

Thanks

dream778
22-10-2013, 03:24 PM
the new driver contains support to dd+/ac3+ for playin sound on all channel runing actually with dd+ and turn normally with images oe2.0 ssl84c but image oe2.0 with ssl84b you must turn off downmix to have sound ac3+.

LichtiMC
22-10-2013, 03:52 PM
that's mean no longer support for dmm boxes,why this decision now? and what consequence assume the user's of dmm boxes with abondon support of openpli?

Bassie already wrote kind of a "prediction" view posts before... pls read... ;)

gjstroom
22-10-2013, 04:11 PM
I make the ac3+ patch in source as well. I hope to release it tomorrow.
My frist priority was to make the new ssl84c work in combination with the latest original drivers.
The ac3+ fix is a simple patch in Enigma2 to assign the right stream id.
The patch is described here: http://openpli.org/forums/topic/30392-dd/?view=findpost&p=380740

jerry
22-10-2013, 06:51 PM
The Arabic font is too small compared to English.
Would it be possible to make it larger?
Thank you very much

Bassie
22-10-2013, 06:58 PM
You can try Mfaraj fontmagnifier to make it bigger.

http://www.tunisia-dreambox.info/dreambox-e2-addons-2/Plugins/enigma2-plugin-extensions-fontmagnifier_0.6.1_all.ipk

jerry
22-10-2013, 09:10 PM
Thanks but the problem is the difference in font sizes between Arabic and English as shown here:
http://i.imgur.com/9585kvH.jpg
I tried font magnifier, but it resizes all fonts with the same ratio.

Edit:
I resetted the scale to 100 at the start of the skin file and tried to increase again, I noticed that now Arabic and English are of equal size in the epg in channel list.
Unfortunately the plugin doesn't resize font in infobar.

I wonder why using the scale in the skin file doesn't affect Arabic font.

Thanks

evgeny
23-10-2013, 08:45 AM
in new image on SSL84C unable to find FAN CONTROL, pakage installed, but menu not available in system settings :(
Playing mkv in mediaplyer again failed after 15min, enigma go to reboot :( new drivers didn't help :(

mfaraj57
23-10-2013, 09:32 AM
You can try Mfaraj fontmagnifier to make it bigger.

http://www.tunisia-dreambox.info/dreambox-e2-addons-2/Plugins/enigma2-plugin-extensions-fontmagnifier_0.6.1_all.ipk
just to correct info
i did not contribute to anything in fontmagnifier

Bassie
23-10-2013, 12:53 PM
My bad mfaraj, i thought you did create.

gjstroom
23-10-2013, 05:10 PM
in new image on SSL84C unable to find FAN CONTROL, pakage installed, but menu not available in system settings :(
Playing mkv in mediaplyer again failed after 15min, enigma go to reboot :( new drivers didn't help :(
About the mediaplayer, the dreambox is not designed to be a media player, some video formats work others don't. Buy a descent mediaplayer !
I think if you restart Enigma2 it will work, if not try visit the PLi forum.

gjstroom
23-10-2013, 08:57 PM
At the bottom of the start post you can find the link to download OpenPLi-4.0-beta-dm800se-sim2-84c-ac3 !

I implemented the ac3+ fix made by Athoik, see http://openpli.org/forums/topic/30392-dd/?view=findpost&p=380825

Please let me know the results, I'll put the patch (and ssl84c/original drivers) in the Daily build if it works !

The image is still 100% build from source code, no binary hacking or image backup methods.

omega
23-10-2013, 10:28 PM
hello, question?
I Dreambox 800SE also load only the Second Stage 84 c in my
I now OpenPLi-4.0-beta-DM800SE # ssl84b

Finaly OpenPLi 4.0 with SIM2 SSL84b and patched 20,131,001 drivers.
where can I necessarily take second stage 84C if I may, of course,

omega
23-10-2013, 10:41 PM
what is the difference between second stage SIM2 SSL84B
and second stage SIM2 SSL84C?

Bassie
23-10-2013, 10:51 PM
what is the difference between second stage SIM2 SSL84B
and second stage SIM2 SSL84C?

http://www.dreamoem.com/showthread.php?8313-OpenPLi-4.0-beta-dm800se-by-gjstroom&p=32366&viewfull=1#post32366

omega
23-10-2013, 11:02 PM
So in other words?
* you may pli an original 4.0 version in the dreambox Laden now?
yes or no

cojo11
23-10-2013, 11:07 PM
only with patch drivers und new ssl

omega
23-10-2013, 11:12 PM
thanks cojo11

cojo11
23-10-2013, 11:14 PM
84c with patch drivers are for 800SE Sim2 only

Aliraza63
24-10-2013, 04:41 AM
i install mgcamd and Cccam and Oscam to this images,but only cccam working fine. This problem with all 84C images. I Request u plz fix the problem

auxius
24-10-2013, 08:35 AM
i tried to install TSmedia 4.2 OE 2.0

telnet: opkg install -force-overwrite /tmp/*.ipk
error: dependencies librtmp0

how do i install this right?

balderdash
24-10-2013, 01:00 PM
i tried to install TSmedia 4.2 OE 2.0

telnet: opkg install -force-overwrite /tmp/*.ipk
error: dependencies librtmp0

how do i install this right?

The way I did it was to extract the files from the ipk and ftp them to there destination and then reboot,
then go into the ts media plugin scroll down to updates and chose library,then install librtmp from there :)

Whether this will break any other plugins that depend on librtmp1 I'm not sure but it hasn't affected any of mine so far ;)

pro-ice
24-10-2013, 05:44 PM
Good afternoon, it is true that the team will not openpli longer supports dreambox !!!!!!!: (

Haroon
24-10-2013, 05:56 PM
At the bottom of the start post you can find the link to download OpenPLi-4.0-beta-dm800se-sim2-84c-ac3 !

I implemented the ac3+ fix made by Athoik, see http://openpli.org/forums/topic/30392-dd/?view=findpost&p=380825

Is it safe to update from box so that ac3+ fix is not effected.

Bassie
24-10-2013, 06:03 PM
Good question, the patching happens in lib/dvb/decoder.cpp
Gjs have to answer on that one not beeing updated?

yiakas
24-10-2013, 06:40 PM
With ssl 84b first download of PLI 4 30/09 for sim2.10 i can install TS MEDIA 4.2 , with ssl84C this is not possible , i can install only TS MEDIA till 3.9.
Is there anything alse in 84C??????

Bassie
24-10-2013, 06:56 PM
With ssl 84b first download of PLI 4 30/09 for sim2.10 i can install TS MEDIA 4.2 , with ssl84C this is not possible , i can install only TS MEDIA till 3.9.
Is there anything alse in 84C??????

No fault of 84c solution overhere from Mfaraj - http://www.dreamoem.com/showthread.php?5808-TSmedia-enigma2-plugin&p=32730&viewfull=1#post32730

Haroon
24-10-2013, 07:17 PM
what about the wifi mate. it doesn't work with 84c and that too on pli. tried your python file trick too but in vain

Bassie
24-10-2013, 07:57 PM
Pli doesnt do the TPM check very wierd it does not work but a new ssl84d with Pli fix is underway very soon maybe This will change things otherwise we have to check it further on, stay tuned :)

gjstroom
24-10-2013, 08:17 PM
Is it safe to update from box so that ac3+ fix is not effected.
First question, does the AC3+ fix work ? Nobody answered that...

If you update and there's something changed in Enigma2 (almost daily), you loose the ac3 fix.
I don't have a solution for this right now. I think the only way is to setup a alternative update feed.

gjstroom
24-10-2013, 08:18 PM
what about the wifi mate. it doesn't work with 84c and that too on pli. tried your python file trick too but in vain
Try a static ip address instead of dhcp.

gjstroom
24-10-2013, 10:16 PM
OpenPLi sim2 #84d

At the bottom of the start post you can find the link to download OpenPLi-4.0-beta-dm800se-sim2-84d-ac3 !

With SSL 84d we no longer need the kernel modifications !

I implemented the ac3+ fix made by Athoik, see http://openpli.org/forums/topic/30392-dd/?view=findpost&p=380825

Please let me know the results, I'll put the patch (and ssl84d/original drivers) in the Daily build if it works !

The image is still 100% build from source code, no binary hacking or image backup methods.

auxius
25-10-2013, 05:07 AM
OpenPLi sim2 #84

At the bottom of the start post you can find the link to download OpenPLi-4.0-beta-dm800se-sim2-84d-ac3 !

With SSL 84d we no longer need the kernel modifications !

I implemented the ac3+ fix made by Athoik, see http://openpli.org/forums/topic/30392-dd/?view=findpost&p=380825

Please let me know the results, I'll put the patch (and ssl84d/original drivers) in the Daily build if it works !

The image is still 100% build from source code, no binary hacking or image backup methods.

can u expain what does "kernel modifications"? i know it's a stupid question.

Haroon
25-10-2013, 09:08 AM
Try a static ip address instead of dhcp.

gj,

sorry, but WLAN option doesn't show at all. on 84b my both wlan sticks are good.

i will try 84d when back from office.

gjstroom
25-10-2013, 09:21 AM
can u explain what does "kernel modifications"? i know it's a stupid question.
No it's not a stupid question. The new ssl #84c didn't work for for OpenPLi, in my search to a solution I found the oe2.0 ssl84c image use a squashfs filesystem for the drivers, OpenPli has the drivers in the root filesystem. That's why I made some kernel config modifications to match the squashfs settings with the original opendreambox oe2.0 image. OpenPli has squahsfs as module, the others embedded in the kernel.
By suprise OpenPLi ssl 84c worked when I changed above in the kernel, no need to really use squashfs drivers. I can't explain that part.
This is no longer necessary with ssl #84d.

gjstroom
25-10-2013, 09:24 AM
gj,
sorry, but WLAN option doesn't show at all. on 84b my both wlan sticks are good.
i will try 84d when back from office.
Is it a supported type ? What chipset ?

alex873
25-10-2013, 09:48 AM
Is it a supported type ? What chipset ?

I try several chips on openpli 2.1 and works fine but in new openpli4 & new drivers fail loading kernel modules i post for support on openpli forum for example
http://openpli.org/forums/topic/30986-problem-with-kernel-module-rt2x00lib/

also fails with integrated chip some 800HDse clone this works fine in 2.1 version

root@dm800se:~# lsusb

Bus 001 Device 001: ID 1d6b:0002
Bus 002 Device 001: ID 1d6b:0002
Bus 003 Device 001: ID 1d6b:0001
Bus 004 Device 001: ID 1d6b:0001
Bus 002 Device 002: ID 148f:3070 ---> Ralink 3070

Regards

Haroon
25-10-2013, 09:56 AM
Railink: Good on openpli 2.1, 3 and 4 upto ssl84b

Aethros: Good on openpli 3 and 4 upto ssl84b.

There is something in either ssl84c or original drivers that both of the sticks are not showing WLAN menu option.

Need to investigate further, why all of a sudden everyone is complaining about wlan.

Aliraza63
25-10-2013, 11:15 AM
Niceee hard work from u gjStroom

auxius
25-10-2013, 01:36 PM
@gjstroom

I noticed that audio doesn't start immediately after a reboot or turning on the box DM800se clone.
I experience it also in "OpenPLi-4.0-beta-dm800se #ssl84c ac3+" other image don't have this bug.

Thanks alot for your hard work.

Haroon
25-10-2013, 02:04 PM
gj,

sorry, but WLAN option doesn't show at all. on 84b my both wlan sticks are good.

i will try 84d when back from office.

Everything okay with ssl84d. Wlan Ok, Cccam ok, mgcamd ok. Picture quality is great too.

jeanbono57
25-10-2013, 05:20 PM
A big thank you gjstroom for AC3 + function
Tests underway for the 84d firmwaire sound works perfectly in AC3 +

auxius
25-10-2013, 05:31 PM
really great image, i'm using it. it's fast and everything was working great. Thnks gjstroom

noliveira
25-10-2013, 06:10 PM
Does hbbtv work in this image? If yes, how??
thanks

gjstroom
25-10-2013, 11:55 PM
No OpenPli doesn't have a browser to play the hbbtv content for the dreamboxes. This is a closed source component.

jerry
26-10-2013, 02:27 AM
I downloaded and tested 84d and it's working great. cccam and ac3 are working properly. The picture quality is great as well.
Thank you very much.

Caruga
26-10-2013, 02:49 AM
greeting

I have problems with the installation of your img, img from ramiMAHER be installed without problems but not yours.

I followed the procedure exactly as written, but still the same problem ...


Flashing failed (!!! 010 INVALID IMAGE (OR OLD VERSION)), box will be unusable now!!

Aliraza63
26-10-2013, 06:58 AM
Awsome and really appreciate the hard work

chandra
26-10-2013, 08:44 AM
Back to this image and thanks for another great work!

Also installed Flash exp. and is working fine so far.
I used a 8GB usb stick with 2 partitions. EXT4 for FE and FAT32 for data like cross EPG.
For some reason XFS partition did nt work for FE initially (crashed with green screen on FE start up), so i changed to EXT4.

Thnaks GJ &team for the hardwork..

talbs
26-10-2013, 01:58 PM
migate to the ssl84d image.
everything went smoothly.

thank you very gstroom for keeping supporting us.

I really appreciate your daily job!

gjstroom
26-10-2013, 04:26 PM
OpenPLi 4.0 sim2 #84d Daily Build
In the start post you can find the link to download OpenPLi-4.0-beta-dm800se-sim2-84d-ac3!

I implemented the ac3+ fix made by Athoik, see http://openpli.org/forums/topic/30392-dd/?view=findpost&p=380825

The image is still 100% build from source code, no binary hacking or image backup methods.

kakaza
26-10-2013, 07:05 PM
@gjstroom

I want to flash nfi image.
So i use plugins dflash version 10.2 and run "mount -t jffs2 /dev/mtdblock2 /boot" backup to /media/usb/backup. It has error and show green screen.

How to backup nfi for this version ?

Best Regards

azrere
26-10-2013, 07:51 PM
Thnks Thnks Thnks..... gjstroom.une superbe image.

LichtiMC
26-10-2013, 08:02 PM
@gjstroom

I want to flash nfi image.
So i use plugins dflash version 10.2 and run "mount -t jffs2 /dev/mtdblock2 /boot" backup to /media/usb/backup. It has error and show green screen.

How to backup nfi for this version ?

Best Regards

Try the dflash version of the feed... (opkg install dflash)
Please report your test-results... ;-)

jomibalo
26-10-2013, 08:10 PM
Off Topic: Noob and (maybe) stupid question(reading but still confused).

I ´m on SSL84b with OpenPli and want to flash the new image? The new SSL 84D is included or need to flash?
Thanks....

Bassie
26-10-2013, 08:11 PM
Yes and do not use 10.2 Gutemine did remove Pli support.
Also be prepared that all versions will expire they have timebombs in the binairies, so soon none will work anymore.

Bassie
26-10-2013, 08:13 PM
Off Topic: Noob and (maybe) stupid question(reading but still confused).

I ´m on SSL84b with OpenPli and want to flash the new image? The new SSL 84D is included or need to flash?
Thanks....

Included no need to first flash the loader with 84b.

jerry
26-10-2013, 08:14 PM
I think this has happened with some previous versions: After flashing and using dreambox edit to upload channels, some satellites (Astra2, Sirius, ...) have channels greyed out and their names don't appear in sat list (only their positions).
Any help?
-----
Edit:
Sorry it was probably because of a wrong satellites.xml file.
Now fixed

jomibalo
26-10-2013, 08:46 PM
Yes and do not use 10.2 Gutemine did remove Pli support.
Also be prepared that all versions will expire they have timebombs in the binairies, so soon none will work anymore.

what did you mean about? can you explain that?

Bassie
26-10-2013, 09:15 PM
No only he is an idiot - http://openpli.org/forums/topic/30936-openpli-stops-actively-supporting-dream-multimedia-stbs/#entry381655

libor
26-10-2013, 10:33 PM
Hi, can not download link pli4.0

omega
26-10-2013, 11:39 PM
Hi, can not download link pli4.0
I agree with the MEGA Terms of Service

Press this button
and then you can charge pli

dream778
27-10-2013, 12:26 AM
hi,i use in flash image oe2.0 ssl84c and now i install meoboot for external flash so the question is :can i install image oe2.0 ssl84d in external flash with no problem,it's possible or not ? if not,can i flach all image oe2.0 ssl84c with ssl84d to have all image with ssl84d?

Aliraza63
27-10-2013, 03:57 AM
Yes and do not use 10.2 Gutemine did remove Pli support.
Also be prepared that all versions will expire they have timebombs in the binairies, so soon none will work anymore.
You mean to say previous version should be used ? , Oh Yes then Whats about NFI Flash backup tool ?

staripper
27-10-2013, 05:36 PM
OpenPLi sim2 #84d

At the bottom of the start post you can find the link to download OpenPLi-4.0-beta-dm800se-sim2-84d-ac3 !

With SSL 84d we no longer need the kernel modifications !

I implemented the ac3+ fix made by Athoik, see http://openpli.org/forums/topic/30392-dd/?view=findpost&p=380825

Please let me know the results, I'll put the patch (and ssl84d/original drivers) in the Daily build if it works !

The image is still 100% build from source code, no binary hacking or image backup methods.

Thanks gjstroom for your great work that we are enjoying.
I've installed ssl84d and latest daily build OpenPLi-4.0-beta-dm800se-sim2, I've turned off the AC3 downmix and got no sound. how can i check if the AC3+ patch is installed?

gjstroom
27-10-2013, 06:27 PM
There's no easy way to check, the patch is in the enigma2 binary.
You can check /usr/bin/enigma2 if offset 00224022h has value 07 instead of 22. But this address can change depending on other Enigma2 modifications.

Please keep in mind, online updates will destroy the ac3+ fix !

Aliraza63
28-10-2013, 06:39 AM
Kindly tell us why Mgcam doesnt work in all 84c and 84d images ? Even Cccam works much better

gjstroom
28-10-2013, 09:38 AM
Kindly tell us why Mgcam doesnt work in all 84c and 84d images ? Even Cccam works much better
Look some pages back, I think it's all there. You can also use the search in topic...

satsave
28-10-2013, 01:09 PM
CrossEPG not working with this image

alex873
28-10-2013, 01:32 PM
CrossEPG not working with this image

works fine for me.

can you tell us what exactally doesn't work?

Seems in last build there are some bugs.

http://openpli.org/forums/topic/31031-typeerror-setup-got-an-unexpected-keyword-argument-close-on-todays-build-when-openning-crossepg-plugin/

Regards

MastaG
28-10-2013, 03:57 PM
gjstroom, now that we have OE2.0.. will you keep updating the OE1.6 feeds for your OpenPLI 2.1 dm800se image?

mfaraj57
28-10-2013, 04:20 PM
openpli2.1 is not OE1.6,oe1.6 and oe2.0 only for dmm images


we have two types of images

openpli and classified to openpli2.1,openpli 3, openpli 4

dmm images and classified to oe1.6 and oe2.0

gjstroom
28-10-2013, 04:57 PM
gjstroom, now that we have OE2.0.. will you keep updating the OE1.6 feeds for your OpenPLI 2.1 dm800se image?
Weird you ask this in the Pli4 thread... But yes the PLi2.1 image are daily updated, as is the feed. But I won't make big modifcations any longer for it.

gjstroom
28-10-2013, 04:58 PM
openpli2.1 is not OE1.6,oe1.6 and oe2.0 only for dmm images
we have two types of images
openpli and classified to openpli2.1,openpli 3, openpli 4
dmm images and classified to oe1.6 and oe2.0
Somehow PLi 3 and 4 are oe2.0, they match the kernel, python and gcc version, but don't have the oe2.0 Enigma2.

satsave
29-10-2013, 06:49 AM
When I try to configure CrossEPG it goes into green screen with errors, I`m using pen drive formatted Ext3


works fine for me.

can you tell us what exactally doesn't work?

Seems in last build there are some bugs.

http://openpli.org/forums/topic/31031-typeerror-setup-got-an-unexpected-keyword-argument-close-on-todays-build-when-openning-crossepg-plugin/

Regards

Jigs24x7
29-10-2013, 09:08 AM
can some one send me the openpli 4.0 backup with installed tspanel and mgcamd

thanks waiting for your kind response

Caruga
29-10-2013, 04:14 PM
MediaPortal and openpli 4.0...

Is it working?

Merdas
29-10-2013, 04:24 PM
Hello my friend

There is a problem happened to me if allowed Is there a solution to the problem is that Internet connection does not function and thank you

musasat76
31-10-2013, 09:38 AM
hello

when flashing image with barryallen ,, after that i cant log on with dcc , the passwd ( dreambox ) not work

i need help and how fix this proplem

thank you

AMIGAnTOMEK
31-10-2013, 01:12 PM
hello

when flashing image with barryallen ,, after that i cant log on with dcc , the passwd ( dreambox ) not work

i need help and how fix this proplem

thank you
How can you flash this image with BA? I think BA not working with OPenPli and 2.0 images for clone.

musasat76
31-10-2013, 10:04 PM
with new bootloader 84d open pli3+4 + oe2 work on clone

southpaw
01-11-2013, 08:23 AM
problem with download link in 1st post for latest daily build, downloads a html file only

gjstroom
01-11-2013, 09:50 AM
problem with download link in 1st post for latest daily build, downloads a html file only
Fixed ! Somehow the auto copy to Mega failed last night.

bugmenot
01-11-2013, 11:08 AM
Somehow PLi 3 and 4 are oe2.0, they match the kernel, python and gcc version, but don't have the oe2.0 Enigma2.

Am I right that OpenPLI ist build from Openembedded 1.6 (http://sourceforge.net/p/openpli/openembedded/). But then DM released OE2.0 OpenPLI still uses the latest OE1.6 (http://sourceforge.net/p/openpli/openembedded/), but is building it's own "OE2.0" with Openpli OE Core (http://sourceforge.net/p/openpli/openpli-oe-core/) ?

But then I don't understand the different OpenPLI-Versions.

OpenPLI 2.1 = more or less OE1.6?
OpenPLI 3.0 = more or less OE2.0?
OpenPLI 4.0 = more or less OE2.0?

Difference between OpenPLI 3.0 and 4.0?

gjstroom
01-11-2013, 01:06 PM
OpenPLi 3/4 is not real OE2.0, because it's not using the closed source OE2.0 Enigma2.
see http://www.dreamoem.com/showthread.php?8313-OpenPLi-4.0-beta-dm800se-SSL-84d-by-gjstroom&p=33199&viewfull=1#post33199
Pli4 is build on a newer build environment and uses newer versions of several libraries (libssl libcrypto, eglibc etc..)
I think you can say PLi3 and PLi4 are both at the same OE level.

auxius
01-11-2013, 05:09 PM
OpenPLi 3/4 is not real OE2.0, because it's not using the closed source OE2.0 Enigma2.
see http://www.dreamoem.com/showthread.php?8313-OpenPLi-4.0-beta-dm800se-SSL-84d-by-gjstroom&p=33199&viewfull=1#post33199
Pli4 is build on a newer build environment and uses newer versions of several libraries (libssl libcrypto, eglibc etc..)
I think you can say PLi3 and PLi4 are both at the same OE level.

plugins that are compatible with OE 2.0 images can also run with OpenPLi 3 and 4 right? OE2 images uses same phyton version used on OpenPli 3 and 4 images.

mfaraj57
02-11-2013, 07:50 AM
How can you flash this image with BA? I think BA not working with OPenPli and 2.0 images for clone.
yes,you can with patched barryallen(http://bbs.dreamoem.com/showthread.php?9101-sim2-oe2.0-barryallen),pli team does not like multiboot but you can install openpli3 and 4 to multiboot only but barryallen will fail to install on box with openpli on flash

Tattisator
02-11-2013, 08:17 AM
gjstroom and mfaraj57,

First I must say that you are doing a great job with all images and plugins ! It is very much appreciated !
Also all your time and efforts to help people like myself with very limited skills....
Since my knowledge is faar away from yours maybe my question is stupid, but I try anyhow

I am VERY fond of the image OpenPli and wonder if it would be possible for you to have the TS-Media and
TS-Panel plugin included in the image so it will be installed when flashing the box. Both in an original box or a clone box
(Dm800 Hd Se) with the latest OpenPli 4.

// T

Aliraza63
02-11-2013, 08:47 AM
in my opinion these are the extensions and these are not the part of the image . clean images gives u the chance to install extensions according to ur demand . and if u need these extensions already installed in image then backup images from some seniors are the best choice .

gjstroom
02-11-2013, 10:32 AM
gjstroom and mfaraj57,
I am VERY fond of the image OpenPli and wonder if it would be possible for you to have the TS-Media and
TS-Panel plugin included in the image so it will be installed when flashing the box. Both in an original box or a clone box
(Dm800 Hd Se) with the latest OpenPli 4.

I build them from source code, it's hard to integrate additional items into to the source code which are not available in git or svn.
I only make clean images, like the original maker intend. Some form of respect.
You can find plenty of backup images on this forum with all kind of 'decorations'.

Tattisator
02-11-2013, 12:21 PM
gjstroom
Thank's for your response, I have tried to find such image without success.
Do you or someone have a linkt to a OpenPli 4.0 image with only the additional TS -Panel and TS-Media included

Thank's // T

tjohoo
05-11-2013, 11:48 AM
I have read the hole thread and one question..
I have today Gjstroom 2,1 ssl84b.
I´m thinkin to upgrade to 4,0..
can i use 4,0 ssl84d gjstroom?
Have sunray4 box..

thanx for all post and support on the thread.. u doing a great work all!!!!

balderdash
05-11-2013, 11:50 AM
I have read the hole thread and one question..
I have today Gjstroom 2,1 ssl84b.
I´m thinkin to upgrade to 4,0..
can i use 4,0 ssl84d gjstroom?
Have sunray4 box..

thanx for all post and support on the thread.. u doing a great work all!!!!

Yes you can :)

DeepImpact
05-11-2013, 02:25 PM
Dear all, i have similar question with tjohoo....
If I flash from my current 2.1 SSL82B to 4.0 SSL84D , am I still able to flash it back (downgrade) to version 2.1 ? just like usual flash SSL82B 1st and follow by version 2.1 ? TQ

Btw, is there any dflash or any backup tools are able to backup OpenPLI version 4.0 ? any recommendation ? thanks in advanced !!! :)

balderdash
05-11-2013, 03:17 PM
Dear all, i have similar question with tjohoo....
If I flash from my current 2.1 SSL82B to 4.0 SSL84D , am I still able to flash it back (downgrade) to version 2.1 ? just like usual flash SSL82B 1st and follow by version 2.1 ? TQ

Btw, is there any dflash or any backup tools are able to backup OpenPLI version 4.0 ? any recommendation ? thanks in advanced !!! :)

If you are on ssl82b you will need to flash 84D first,then the image

If you are on 84B then just flash the image

Basically you can go up and down between ssl84 images without need to flash ssl providing the image is a patched image :)

But if going between ssl82 and ssl84 you need to flash the corresponding ssl

LichtiMC
05-11-2013, 09:25 PM
Dear all, i have similar question with tjohoo....
If I flash from my current 2.1 SSL82B to 4.0 SSL84D , am I still able to flash it back (downgrade) to version 2.1 ? just like usual flash SSL82B 1st and follow by version 2.1 ? TQ

Btw, is there any dflash or any backup tools are able to backup OpenPLI version 4.0 ? any recommendation ? thanks in advanced !!! :)

Your first question:
As I know you can always just flash the image, because ssl is included.

Second one:
Thanks to mfaraj57 we have this: http://www.dreamoem.com/showthread.php?9183-NFI-imagetools-version-2.0-plugin
You can backup and flash images with it... ;-)

Regards

Fluff
06-11-2013, 08:49 AM
Hello.

I can't get wifi to work. Could some confirm that it should work with this image?

I tried to do some debugging and one of the things i noticed when i do ifup wlan0 i got a message:
wlan0: Own Mac address ff:ff:ff:ff:ff:ff
At boot i got:
r8712u: DriverVersion V7_0.20100831
and a different max address.

DHCP isn't working, i have also tried adding ipadress manually with no success.

desolator
06-11-2013, 01:41 PM
Install manually an magcam cam

then via telnet these command


cd /tmp
wget http://downloads.pli-images.org/feeds/openpli-3.0/dm800se/mips32el/libcrypto0.9.8_0.9.8x-r15.0_mips32el.ipk
wget http://downloads.pli-images.org/feeds/openpli-3.0/dm800se/mips32el/libssl0.9.8_0.9.8x-r15.0_mips32el.ipk
wget http://downloads.pli-images.org/feeds/openpli-3.0/dm800se/all/libcrypto-compat_0.9.7-r4_all.ipk
opkg install libcrypto0.9.8_0.9.8x-r15.0_mips32el.ipk
opkg install libssl0.9.8_0.9.8x-r15.0_mips32el.ipk
opkg install libcrypto-compat_0.9.7-r4_all.ipk
opkg install enigma2-plugin-softcams-mgcamd

edit the mgcam.cfg and define box type instead of auto detect


B: { 06 }

I confirm that is working perfect

chandra
06-11-2013, 05:44 PM
Hello.

I can't get wifi to work. Could some confirm that it should work with this image?

I tried to do some debugging and one of the things i noticed when i do ifup wlan0 i got a message:
wlan0: Own Mac address ff:ff:ff:ff:ff:ff
At boot i got:
r8712u: DriverVersion V7_0.20100831
and a different max address.

DHCP isn't working, i have also tried adding ipadress manually with no success.

i have tried many builds of this and never had an issue with wifi. so it should work in your case.

desolator
07-11-2013, 10:11 AM
guys i have one question for you

on the previous builds of this image the picons where automatically downloaded, now it's not getting any feed to download picons, is there any way to add it manually on the box or the image must be rebuild, or am doing something wrong, there is no option about picons path on this image